Hype container won't load after refreshing browser


#1

Hey guys,

I have this issue with my website and can’t seem to figure out how to fix it. I need a little help. :smiley:

Here’s the issue:
When I refresh the browser, the HTML loads, but the JavaScript isn’t displayed in the browser. There’s a certain issue with the animations, or something, because:

When I refresh before the menu box starts to expand, it refreshes fine and the JavaScript does load.
When I refresh _after_the menu box has expanded, it just shows plain text and no hype generated content whatsoever… refresh after refresh after refresh. Same result. Just plain text of content…
Same result in both Safari as in Chrome.
Same results on MacBook as on iPhone or iPad.

I’m lost here. Anyone have any ideas?
Take a look for yourself: www.iwonder.amsterdam

All help is appreciated!


#2

The generated script file URL in your cache.manifest is different to the actual script file (because of the “cache buster” numbers at the end). I would try uploading without the ?###### number like *hype_generated_script.js) seems it’s a cache problem. OR change the manifest to cache without the ?######


#3

Thanks for the suggestion. I’ll try it out and post my findings. :smiley:

[edit] The problem was actually fixed after changing the number in the gsfURL in the cache.manifest. Weird, though, how there was a discrepancy in this, since both would have to have been generated by the Hype.app itself… curious…

Thanks a lot for your help, man, would have never figured this out on my own!