Hype animation not showing because script overflow:hidden

I am using tumult hype animation wordpress plugin.
Some animations are not showing even I use same shortcode as others which is showing properly.
The source code of page was like <div id="koreanlettertable_hype_container" class="HYPE_document" style="margin:auto;position:relative;width:100%;height:100%;overflow:hidden;">

I guess the css script "overflow:hidden" causing the problem.
Why the plugin make script like this and how can I fix it?

Your assumption is most likely wrong, overflow hidden is not causing the problem. What is causing the problem is the setting of 100% height in the context of a parent DIV with no height. Meaning, if the container you embedded it in does declare some sort of height … Hype will be 100% of 0px.

The solution is to give:

  • Hype a height in the application (fixed value)
  • the surrounding DIV a height (fixed, or based on vh etc.) in your WordPress Builder of choice
1 Like

Thank you. It was solved by setting a fixed height in hype app.