Hide scrollbar on Microsoft Windows


(ioserg) #1

Hi, I use iframes a lot and they look great on a mac, but when I see it on a windows pc, it shows up with a visible scrollbar.
I found a workaround by making the iframe bigger than the pixel dimension, but when I need to use percentage instead of pixels, there´s no way I can use the same method of making it bigger.

Is there some code I could insert to make it disappear? and if there is… Where do I paste it.

Thanks


(info11) #2

Add some extra code in the iframe…
Set scrolling to no.
See example

“iframe src=“http://www.your-website.nl” frameborder=“0” scrolling=“no” height=“250px” width=“250px” >”

Good luck


(ioserg) #3

Thanks for your help, but the code didn´t show anything (I added a working link).
I personally use this code for the iFrames:

and tried to add: scrolling="no" And I still get the scroll bars. Is there anything else I could do?

(Freelancer) #4

@ioserg, I’ve experienced the same issue; I think it’s a Windows Chrome thing. All the Mac browsers don’t show scrollbars; on Windows, Firefox and IE11 don’t show it but Chrome does.

Not sure why, or if there’s a workaround, though.


(info11) #5

Hoi ioerg and johnapurdy,

I’ve tried it out on my server. And everything works fine here now scrollbars in Chrome, Explorer 11, Firefox or Safari.
(iframe src=“http://astore.amazon.com/treemousepads-20” width=“500” height=“450” frameborder=“0” style=“border:0” scrolling=“no”)(/iframe) ( ) must be changed in < >. Did you all update to the new Beta version 3.0.0(444) of Hype today??

See: http://84.82.40.191/index/

Strange that this occurs.
In the previous beta version. When I used an iframe the page displayed stayed blanco. But in Hype 2.5 the page was displayed normal.


(Jonathan Deutsch) #6

What browser version and os version are you specifically seeing this on?

I vaguely recall that setting a body CSS property of overflow: none; for the inner content might also help.


(ioserg) #7

I think the problem is with the OS, because (Safari, Chrome, and firefox) all hide the scrollbars on OSX. When I test it on Windows 7, it doesn´t matter which browser I use (Safari, Chrome, or firefox).


(ioserg) #8

You´re totally right info11. I was using the code “” and I just inserted the frameborder and the scrolling. After just copy/pasting your code it just worked!
I didn´t think the order would matter, but I guess it does. Thanks a lot, you just made my animations a lot better. :smiley: