Hidden Elements exported


#1

For some reason all Hidden Elements on my timeline are loading after export. The elements are hidden, but using web inspector on safari I can see that all elements were preloaded.

Hype Documentation clearly states that “When set to ‘Hidden’, the element will not appear on the scene or in export”

Is this is a new bug in v3?


#2

No bug.

The Display “Visible” / “Hidden” is connected to the CSS display property. It’s always going to show in the source code just not in the output. It’s like the “text output for search engines” that is produced on export too.


(Mark Hunte) #3

I think the wording in the Documentation could be a bit clearer on this. It talks about two different settings in the same paragraphs. I think it should explain them separately and not talk about one type in the others to avoid this confusion.

There are two notions of ‘Hidden’:

Element Visibility & Locking

Clicking the eye icon for elements in the element list will Hide the elements on the scene and they are also not included in the exported document.
Hiding elements this way is intended to not include them in the final export but to keep them available in the project for your use.

Opacity & Display

Setting the Display value to ‘Hidden’ in the property Inspector for an element will set the CSS Layout property display:none on that element; this is an animatable property. Use the ‘display’ option during animations to instantly hide or show an element on the scene.
When elements are hidden this way they are included in the export and will be hidden on the scene but they will only be interactive when they become visible.


#4

Mark,
Element Visibility & Locking is what I had in mind. If I hide an element in timeline by clicking the eye icon I still can see assets being exported and they are loading in the background when I open the page. Is this is normal with hype? perhaps there is a way to disable hidden elements from being exported so my published content does not take so much space.


(Mark Hunte) #5

Well AFAIK they should not, I just did a test and you are correct they do still get exported!.

I just found another thread on this

Which is inconclusive as far as I can see in what really should be happening.

I also had a look at the Advanced export but could no stop the export of an (eye) hidden element there that I could see.

@Daniel,

Did you manage to find out what should happen when exporting (eye) hidden elements.?

Cheers.


(Jonathan Deutsch) #6

This is a bug; items with the visibility disabled (aka the “eye” icon) shouldn’t be exported but incorrectly are being so. It looks like this was somehow wrong since we first shipped the feature in v1.5 – even my What’s New in 1.5 video says these elements aren’t exported!


#7

OK. So I misread the question or didn’t realise you were meaning the “eye” and “lock” in the timeline. Indeed as Jonathan points out this is a bug. I thought you were referring to the new(ish) Display area in the inspector. My Bad


#8

Thank you Jonathan for clarifying this. Do you have any idea when this bug will be fixed.


(Jonathan Deutsch) #10

Sorry, I can’t give a promise when this will be fixed or even if it will be fixed - there might be some users relying on this behavior and it could break their animations to change it. I need to do further investigation and beta testing. It also isn’t a simple change (despite seeming like it might be!).


(Mark Hunte) #11

A simple approach to counter that and maybe satisfy everyone is to maybe to leave it as it is but just add an optional check box at the export dialog.
This way the default is to export them but at the last stage you can decide not to.