Full Physics No rotation Z


(Nim) #1

Hi all,
is it possible to prevent the Z rotation for the Full Physics body objects?
This is the animation
http://nimstudios.com/banner/convivio/300x600/Default.html
I wouldn’t have Z rotation

Thanks!


#2

You could periodically run a relative timeline which animates the Z rotation to 0 for those elements over a second or so. Just make sure that it has some time at the 0 degree rotation in your animation so that its ‘correction’ doesn’t result in any additional rotation velocity.

To make a timeline relative, check the ‘Relative’ checkbox in the Scene Inspector > Animation Timelines area:

22 AM


(Nim) #3

Thanks Daniel, Actually I already tried to do it, but if I set a Z rotation to 0 the object stops, and It’s not more affected by physics…
I did an animation from Z -1° to Z +1° all timeline long. it that correct? or It should be just 1 sec or so…?


(Nim) #4

wait wait wait…I gotta do the Z rotation to 0 in the main Timeline on in a new Timeline?


(Nim) #5

YEAH! with a new Relative Timeline which controls the Z rotation to 0 for each element IT WORKS!!!
Thanks Daniel, sorry I didn’t get you at first shot! :wink: