For Public Display..! (How to, what do I need)


(James Rose) #1

Hi Guys,

So with thanks to @MarkHunte I’ve made a controller for use in a public space, however I need it to run in a pretty locked down way, I know I can do this using safari to create the home screened web app, however can i disable the 5 finger fullscreen close gesture?

or use a different browser for a solution etc?

Any help much appreciated as always :wink:


(James Rose) #2

No sooner than I ask I think I found the get rid of gestures setting on the iPad. It’s within

Settings > General > Multitasking > General (1/0)

Any other solutions that might improve on my crude solution welcome :slight_smile:


(James Rose) #3

HAHA @MarkHunte to the rescue again it seems! Though is this only for OSX not iOS?

:grinning:


(Steve Warby) #4

You can put an IOS device into a kiosk mode if this helps.

Cheers

Steve Warby


(Mark Hunte) #5

The one thing about this is if you are viewing through Safari, I think even with either kiosk option that @classic12 provided the users may be able to navigate away from the page.

Personally I would quickly make my own browser in Xcode that did not have an address bar for instance and use the Single App Mode option.

Which means even if the user selected an object or text in the browser they most likely will not be able to call up Safari by using the define contextual and then search web.


(Hans-Gerd Claßen) #6

hi mark, for iOS¿


(Mark Hunte) #7

Yes, for iOS.

Here are some screen shots of a web app I quickly made last night , that cannot go any where other than the loaded page.

But even that gets the contextual menus. So I figure with the single app mode and this app set to it, even if they can get this menu they will not get any where as to do so would need to open Safari etc.

I am looking for a way to disable these menus.



Long time NO Tute ;-)
#8

If you’re viewing the doc in iOS safari you can use CSS to disable the long touch menu and selecting the element

selector { 
    -webkit-touch-callout: none !important;
    -webkit-user-select: none !important;
}

(Mark Hunte) #9

Nice.

I will also add that when I get back and see how that works on the custom browser since they use the same engine it should work.

Thanks


(Mark Hunte) #10

Thanks @DBear,

That did not initially work I thought it was an iOS 9 thing.

But I then tried

	body { 
    -webkit-touch-callout: none !important;
    -webkit-user-select: none !important;
}

Which seems to work a treat in the custom browser app.