Font not changing colour?


(lee) #1

sooo I cant change font colour… I think I am doing something very obviously wrong!

https://youtu.be/Rs-yrqMHadY <- screen record


(Rick) #2

No idea how to fix that. I have encountered that before myself that I couldn’t change the font color. Some (frantic) double clicking (damnit work!):grimacing: :kissing_closed_eyes:refocusing the app on something else then retry it again and it suddenly worked.

Sometimes weird stuff happens. I had a button with one action set to it: continue timeline A which worked yesterday and this morning when clicked the button flew out of the screen with no action applied. In the end recreating that button fixed this. :face_with_raised_eyebrow:


(lee) #3

It is happening with Anything I copy and Paste… because I do a lot of localization work this is massively frustrating :(…


#4

Yes, this is what happens when copying~pasting formatted text into Hype.

Select the “InnerHTML” of the text element in question (“Edit” Menu > “Edit Element’s Inner HTML” or “Option~Command-E”).

You will see HTML markup which is overriding Hype’s own formatting commands (this “inline” markup has a higher level of specificity than Hype’s user interface).

You can clean the formatting out manually or, as one possible alternative, paste all text into the “TextEdit” app first. Next select: “Format” menu > “Make Plain Text”. Now You can copy and paste the desired text from this “plain text” conversion into Hype.


(lee) #5

ohhhhhh snap that is a cool feature…!

I don’t even care that sometimes the font colour doesnt work knowing I can instantly edit the html/css like that. Thats awesome :slight_smile: Thanks!