First Scene On Scene Load Play audio stopped working

Hi there, a rather odd thing has happened to an almost finished Hype project. I have an On Scene Load behaviour to play a sound (small music clip) and also a Timeline Action of Play Audio on the first scene which until now worked perfectly. However, after doing some client amends (nothing to do with the first scene at all) when I preview in all browsers, the first scene's audio doesn't play. All the other scenes audio plays as expected and when I get to the end of my project (a simple quiz) I have a buton which takes the user back to that first scene and the audio plays okay ...

I have tried deleting and adding back in the behaviour/action and audio file, changed the audio file and it still doesn't play.

Anyone else experienced this and found a solution?

Many thanks, Bob

Audio should only be played in response to a 'click' or 'tap' -- I'm confused why this ever worked.

Because the audio is played immediately after a tap, it will respond as expected. This is your browser protecting you from sounds that occur without user interaction.

Please read: Controlling Audio & Advanced Techniques (AutoPlay, Play, Pause, Rewind, Volume control) This workaround might be helpful for you: No Audio in Hype? - #15 by Daniel

1 Like

Thank you so much for confirming! That makes perfect sense. Not sure why it worked originally – probably had a button or something which got deleted along the way knowing this client.

Have to say, this is the first time I've used Hype for a real client job and it has proved to be fantastic and made me look like I know what I'm doing ! Which clearly I don't! All the help as well from others on this forum has been outstanding – so thank you everyone!

Have a great weekend when it comes!


Glad that did the trick! And always great to hear that you feel empowered to do tricky stuff with Hype with the help from the kind folks on the forums.

1 Like