Failed to load resource: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 303.)

Hello @Daniel,

This issue is related to Hype wordpress Plugin.

Recently, we upgrade our SSL to make it compatible with latest browser update, like Firefox, Chrome across more device and OS. and here is detailed process if you like to know more:

After that, when I upload Hype project at backend with OAM format, a issue happened as screenshot:

And I tested in Chrome and Firefox, the issue is same and reproduced.

I searched for the reason, and this post might be helpful for your referrance:

In this case, any uploading will be failed.

Is it possible to resolve this issue please?

Thanks

Hi @Daniel,

In Chrome, it looks like this:ERR_NETWORK_CHANGED

or, like this way:

Alex

This is very odd – and this isn’t happening with any other plugin?

The plugin does not make any protocol-specific URL references. It uses the base URL of the site’s URL to build any URLs required to use the plugin, load assets, or reference the uploaded Hype documents.

It sounds like the response sent after an upload is not coming through correctly – it’s causing something that looks like a redirect loop. I have a couple test sites that both work over SSL: One with Cloudflare, and one with a NFS script handling the SSL cert. Both are working correctly with OAM uploads.

When I try to run the SSLlabs test, I get this error: Assessment failed: Failed to communicate with the secure server and it looks like the domain is down.

Today, we add TLS 1.3 Support with SSL, but same issue.

And you can check our ssl at https://www.ssllabs.com/ssltest/analyze.html?d=www.lovcour.com

If you see that error again, please show me a screenshot, thanks.

After tried more, I found that I can upload three OAM files successfully,

One is 4.4MB
one is 2.9 MB
one is 3.7 MB

It seems that if the file is large than 5MB, it will fail, and just show the error as the screenshot:

Attached is our php.ini, about file size limitation of uploading, and it would be great if like to have a check. thanks.

php.ini.zip (22.8 KB)

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 300M

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20


but there is also another setting in PHP.ini:

; Maximum size of POST data that PHP will accept.
; Its value may be 0 to disable the limit. It is ignored if POST data reading
; is disabled through enable_post_data_reading.
; http://php.net/post-max-size
post_max_size = 8M


Anything wrong?

I changed it to

post_max_size = 50M

seems it work.

Sorry, this issue is not related to plugin, but related to Php.ini setting:

https://secure.php.net/manual/en/ini.core.php#ini.post-max-size

post_max_size integer

Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize. Generally speaking, memory_limit should be larger than post_max_size .

The right setting should be:

memory_limit> post_max_size> upload_max_filesize.

Thanks for letting us know.

No thanks.

FYI, I found TLS v1.2 is not so compatible with HTML 5, but TLS v1.3 works well with HTML5.

In enverioment of TLS v 1.2, some images and animation will not show up.

If needed, I can switch from TLS v1.3 to TLS v1.2 for your check and test.

Alex