Exported file as HTML file

Hi there
I exported my hype file as one HTML file, but when i send the full folder (HTML and Images folder) and my client try to run the file on his mobile (android ) the html page is just a blank page, any advice

Some questions and hints:

  • Hype is based on JavaScript and needs it to render. So, make sure that your client hasn’t got that disabled or blocked?!
  • Have you put the folder on a server and sent him a link to the file? How does the client open a ZIP on Android? It needs to be full unpacked.
  • If you use certain JavaScript functions often file:// access is blocked but this hint is only valid if you programmed some fancy relative include.

Best regards!

thanks max but i think i wasn’t clear enough, my client is need to run this file local on his Smartphone, so he download the zip file and extract it on his phone, but he just got a blank page when he run the HTML file :frowning:

Do you have ‘use offline application cache on’? (I recommend turning this off)

Can you have him send a screenshot of what the .html file and the documentname.hyperesources folder look like on their device after unzipping?

The best thing to diagnose what’s going on is to run Android / Chrome devtools: https://developers.google.com/web/tools/chrome-devtools/remote-debugging

But my guess is that the .html file is trying to load content from the resources folder and it’s unable to do that…

exactly, he couldn’t open the hype_generated.js file, so HTML file load nothing :frowning:

Can you outline the steps they take to unzip + load the file?

I zipped the exported HTML folder from Hype, i sent it to my self with transfernow, then i downloaded it on my phone, then i unzipped it in a separate folder…
this is all the steps, but when i open the HTML file i got a blank page,
By the way i tested it on my pc and it worked, the problem when i tried to run it on my phone

My guess is then this isn’t a Hype Problem. Rather, unzipping on a phone means your installing it on a local file structure and something is going wrong there. But that could be the fault of the unzipping utility or sand boxing on the device.