Enter viewport bug?


(Teo) #1

Hi,

The ‘On Enter Viewport’ seems to have a problem when used in combination with a scene size locked at 100% width - see attached example :

  • the animation timeline (‘test’ in the example) is incorrectly started once the scene loads
  • and then correctly started again when the trigger element enters the viewport.
    (if the scene width is not locked at 100%, all goes well)

A simple way around that involves stopping the animation at the beginning of the main timeline, but it is not optimal - do you have any suggestion ?

Many thanks,
Teo

test.hype.zip (19.3 KB)


(Greg) #2

Is there a reason to have the elements grouped? It seems to work when I ungroup them.


(Jonathan Deutsch) #3

It does look like a bug; I have this filed in our system now to fix.

Specifically it only has an issue if the “Zoom contents” option is used in the group. Are you able to have the flexible layout behavior you want without this option?


#4

Has this problem been solved yet - or is there a way around it?


(Jonathan Deutsch) #5

Sorry, this has not yet been fixed but is categorized as a high priority for its correctness.
The workaround is to not use the Zoom Contents option or place the element with the viewport action outside of the group that has zoom contents enabled.