Embedding video in a Wordpress site: HTTP within an HTTPS page

Hi @jonathan @Daniel

I met headache issue with video play only in Safari after SSL setup when I try to embed video into Hype project.
and later I found it is not related to Hype, but if it is not resolved, I can not continue Hype work, so I hope any one would like to share your expeirence.

The issue is video playing in Safari after SSL setup. those Videos play well both in SSL or non-SSL status in Chrome and firefox. I supposed the reason seems related to incorrect intermediate certificates setup, as per at technical topic https://stackoverflow.com/questions/4660189/cannot-view-quicktime-movies-over-https-in-safari-or-uiwebview

so, I asked an technical to setup new wildcard SSL for our multisite(Payable work for wildcard SSL deploy), and created a fresh site with no plugin activated, you may find SSL work well:

Here is my test process:

  1. by default, the site was created http://videotest.lovcour.com/(not https), http://prntscr.com/jdygmc

2.I check the root site, it is still http://lovcour.com, but not https://lovcour.com, I just support it is saved in database but I can not change it.

3.if access the subsite: both https or http is accessible ://videotest.lovcour.com

4.Upload a standard mp4 video sample downloaded from a professional development site which guarantee the video is support in all of browser,

  1. the default url of the uploaded video is http://videotest.lovcour.com/mp4_video/, it is not https, please check the screenshot: http://prntscr.com/jdyj3z, and the video is play both frontend and backend, and Here is frontend screenshot: http://prntscr.com/jdyj9u

6.Here is screenshot: http://prntscr.com/jdyjtt, which show I changed the site url from http://videotest.lovcour.com/ to https://videotest.lovcour.com/.

The video URL will automatically change from http to https, here is screenshot: http://prntscr.com/jdykag

As you see, the video will not play both at backend and frontend, and just show the error as:

Media error: Format(s) not supported or source(s) not foundmejs.download-file: https://videotest.lovcour.com/wp-content/uploads/sites/59/2018/05/mp4_video.mp4?_=1

I would like to have your professional suggestion, how to resolve it please?

Thanks so much.


It is looks like the uploads directory is not using SSL so your files will always be http and not https even though you have changed the site URL.

Unless someone here answers with a fix I would suggest you ask on the wordpress forums

1 Like

Hello @MarkHunte

I can fix mixed content by using a plugin to forcel SSL


if so, the video will completely show error


I looked into this a little bit the other day, but unfortunately I couldn’t figure out the exact root of the problem nor do I know how to fix it. @daniel does have a lot of knowledge about the weird server config issues other users run into, so he may know better (he’s out until tuesday though).

Probably the next steps would be to look at the HTTP(S) headers that returned by the requests and see how they differ from a valid vs. invalid request. I’d also see if there are any redirections and if you’re losing some data from those that invalidate the security somehow. Beyond that if it is more of a cert issue I’m not sure the best way to debug since your certs do look okay to me.

It might be best to open a new question on stack overflow since there are probably more SSL/HTTP experts there.

Hi @jonathan,

Thanks for your suggestion.


Just wanted to follow up to this and consolidate other threads where this is being discussed. Do you have any updates @alexlii?



thanks,it was resolved for me by reinstall whole Wordpress, but is really complicated to explain.

We are using a server management tool of easy engine, that issue is related wildcards ssl setting of let’s encrypt and Easy engine(https://easyengine.io ) , wildcard ssl seems only compatible with the latest version of easyengine.