Code Snippets and Snippet Editor broken (v208)

Something really strange is now happening with the Snippet Editor / Code Snippet section.
Moving Snippets or even sometimes editing them seems to overwrite existing snippets.

Additionally there seems to be an autocomplete? bug where typing 2 dashes – too quickly gets replaced with an em-dash —. This might be ok in an app like MS Word, but in editing code, I’d think I should be able to type as quickly as I can.

Whisk - Snippet Editor - Watch Video

1 Like

This surprises but doesn’t shock as this build does have snippet editor changes to make it resizable. I can’t reproduce the problem though; would you mind sending a report via the Help > Report an Issue… menu that is set to “Send logs, preferences, and system information”?

Also are you/have you used multiple monitors on that machine?

Thanks!

Whisk explicitly disables this! I don’t get why you would be hitting it, nor can I reproduce it either. Do you have any non-standard keyboard/input managers setup?

Nope - pretty vanilla 2019 iMac 27" 3ghz i6

Nope again - same stock Apple KB and mouse that shipped with the iMac

Odd; can you please send a report the Help > Report an Issue… menu that is set to “Send logs, preferences, and system information”? There’s no need to fill out anything other than referencing this thread. The preferences file and log it sends is the most useful next step to figure out what is happening.

Thank you!

Gotcha - this has been sent.

1 Like

Got it, thanks!

In trying to track these down I took a closer look at this post…

I previously just looked at the embedded GIF thinking that was the whole problem, and therefore the issue was the snippet editor wasn’t opening! Now I see the full video and can reproduce the issue with duplicate snippets. Thanks for taking the time sending me all the extra data :sweat_smile:.

Likewise on a closer look of the video I can see that you were trying to do the dash-dash in the snippet editor. I had wrongly assumed you meant the main source editor. The snippet editor doesn’t disable the rich text options so I will fix that for the next release.

Thanks again!

1 Like

All of these issues have been fixed for the next beta.