Cannot upload any new .oams to Wordpress except the first one I uploaded

Hi, I was enjoying Hype 4... uploaded my first exported .oam file to my Wordpress site with the Tumult Hype Animations (v1.9.5) Wordpress plugin and it appeared just fine. Then after some more edits and tried to upload the next version... the Wordpress plugin always gives me the same shortcode (id="0") and doesn't list any animations as being uploaded... And the animations won't appear.

If I re-upload the original .oam file I generated first that animation appears, but I can't get any other .oam files to appear.
I tried:
reverting to much older files and generating more oam files, removing any numbers from the .oam filenames, removing any numbers from the names of the objects/elements in my design, creating basic new animations from scratch and generating .oam files, restarting Hype, restarting my machine, reinstalling the Wordpress plugin, reinstalling Hype (on Mac)...
Nothing works. Only the very first .oam file I generated works.
Please help!

I saw these questions in a similar post that didn't resolve the issue, so posting the answers here too:
If the file size of the oam is too large, it might silently fail. Does it work with a super simple / small oam file? The files are less than 300KB
Are you able to upload images in your media library? (This helps figure out if there are permissions errors with your WP installation) Yes
Do you know what version of PHP the server is running? Er... it's running Wordpress 5.7.2

I also tried uploading a copy of the .oam file that works, but re-named, and this doesn't appear... So it doesn't seem to be an issue with the .oam files, but with how they are uploaded... It only likes the original .oam file with its original filename... And always gives the same shortcode...

But... if I rename any other my other .oam files to the same name as the working .oam file... it's still blank...


Hey Ben,

Sorry you're hitting this!

Any server migrations or changes to the server since it worked?

Can you try a simple file, exported as an OAM file, using the name 'test' when exporting (anything under 1mb)?

Make sure you do not rename the oam file prior to uploading.

I'm not sure what you mean by 'original' here -- are you having issues uploading a OAM file using the same export name? Are you trying to make two separate uploads using the same name?

Note that changing the OAM file prior to uploading is not advisable - the ID of the Hype element is the same as the filename, and the filename is setup to link to the Hype element. There's also a bug where files can't start with a number or underscore, so try just simple lowercase names a-z. If that doesn't do it, can you share your login info with me so I can test things out? You can click 'Message' on my profile page here: Profile - Daniel - Tumult Forums and send me a private message.

Or set him up as an Author. So you do not have to share admin login.

Thanks Daniel for your quick response. Just to confirm, I'm not renaming the files after generating them... I'm just generating more oam files from my animation project but saving these with different names. (no spaces, hypens... etc, I had original appended numbers, but removing those has no effect).

Any server migrations or changes to the server since it worked? None... and the very first .oam file still works fine whenever I re-upload it....

Can you try a simple file, exported as an OAM file, using the name 'test' when exporting (anything under 1mb)?
I tried this... simple file exported as .oam called "test", and still have the same problems.

Make sure you do not rename the oam file prior to uploading. Yes

So just to summarise the issues.

  1. Whenever I upload an oam file using the Tumult Hype Wordpress plugin it lists that no files have been uploaded and always returns the same shortcode each time ([hypeanimations_anim id="0"]). Therefore I can only display at most one animation.
  2. The only oam file that appears using the shortcode is the very first one I uploaded (I also tried the short code [hypeanimations_anim id="1"] incase my subsequent uploads were going elsewhere etc).
    Every other oam file I generate and upload, whether from that animation project or any other I try does not display. But if I re-upload that very first oam file, the animation immediately appears on my site. (If I make a copy of that oam file with a different filename and upload that, it won't appear).

The site page is and my animation is of cargo containers moving through a shipping process...

The problem doesn't seem to be the plug-in itself (since I reinstalled it), it doesn't seem to be the animation tool (re-installed it, re-started my machine), it can't be the way my animation is configured (tried creating very basic files from scratch, just with a word or a picture and nothing works). I've seen the comments on width = 100%, this is how all my animations are configured...

I'm wondering if it's something to do with how the plug-in is interacting with Wordpress. I have a fresh Wordpress environment, up-to-date but not updated or changed since it was created a few weeks ago. I am using EasyWordPress hosted on Namecheap. My site has a Theme called Zakra.

Here's something weird. I tried generating an .oam file with the exact name of the first one I uploaded that works "GreenChannel.oam", (not changing the filename after generating but chosing the same name when generating it). Before uploading this file, nothing was showing on my site (the last file I uploaded was not appearing). After uploading this new file (with the same name as the original "GreenChannel.oam") the original working animation appeared(!) Not the animation I had just uploaded, but the first animation(!)

It seems that the plug-in/Wordpress will only save that first file id=0 ... It won't add id =1 or update id=0 and if I try to replace that file with another that has the same name it reverts somehow to the first file uploaded... could it be an issue around file save permissions? (I'm not an expert in how Wordpress does this).

Note I am using the trial verison with 13 days remaining, and I was just about to purchase... But I don't think that could be the cause of this strange behaviour...

It seems like something is blocking the normal filesystem access the plugin requires -- this might be a restriction imposed by EasyWp. I'm in touch with their support staff, but at this time the plugin will not work as designed on

1 Like