Bug plugin "Tumult Hype Animations"

wordpress

(Pierre) #1

Hello,

and the responsive dimension: invisible online animation

I had already discussed this topic on the forum but after a new installation of the plugin Tumult Hype Animations on a new site, the problem is still present.

If I publish an animation with the option 100% (in “default size”), I export a .oam file, I import it using the Tumult Hype Animations plugin, and when I display my web page, animation is invisible.

If I publish an animation WITHOUT the 100% option, it works perfectly.

This is a real problem that prevents me from using my Hype animation on websites.

Could you try this test with my basic file?

Pierrehyp-test-plugin-oam.hype.zip (176.8 KB)


#2

Check out the troubleshooting section of the Wordpress Plugin page: Tumult Hype Animations Wordpress Plugin

When embedding something with a 100% height into something with no set height (like a Wordpress post), the calculation is as follows: What is 100% of auto – unfortunately the answer is usually 0 which results in the animation not appearing since the height of the Hype embed is 0. So to workaround this, set your ‘width’ scaling as 100%, but don’t check the ‘height’ scaling checkbox. Of course there are workarounds to getting a fully responsive document embedded in Wordpress, but if you are actually trying to make a Hype document fit the whole size of the browser, you might not need Wordpress as your frame.

It would be helpful to see how you intend on embedding this document into your site (and seeing its URL) and hearing from you what you expect to happen at different browser and mobile browser dimensions.


(Pierre) #3

You answered my question
Thank you very much, it works;)