Browser's console giving a lot of 'info'

I’m nearning the completition of my website (desktop-dark variant). Just a few alignments, text changes, etc. are left. So, I just uploaded it to server to do some checks (some cookies were supposed to set only on my domain, etc.). So, a huge part of the wesbite worked correctly. However, I’m facing a few issues. They’re listed below:

  1. The browser’s console is throwing a lot of ‘info’ (see screenshot). The numbers just go on increasing as I hover my mouse over the elements on which I’ve set some mouse hover actions. I can ignore this problem because it doesn’t seem to cause any issues with the usability of the website. But, I’d like the console to be clean.

  1. My scene 404 and 404 aren’t working as expected. I’ve set a cookie warning on all scenes and added a function to remove those if a cookie named privacy with the value yes exists. It’s working on all scenes, except on 403 and 404. I’ve no idea why. That’s giving some syntax error in console (see screenshot). The same error repeats if I click on the ‘Got it!’ button to dismiss the warning. This is a serious error and I have to rectify it.

My website is available here to check:
(choosing any theme, dark or light won’t make any difference because both the folders have the same files uploaded in them).

I’m also attaching my .hype document. It’s available here:

My testing environment is Google Chrome Canary 76 on Windows 10. I’m testing in the ‘Guest’ account in Chrome so that there’s no cache, cookies, extensions, etc. that can conflict.

You are using a selector (I guess to determine currentScene) something seams to be off. Hint by looking at the screenshot. Not currently in the office. Anybody else?

Yes, I have to use the seector as I had discussed in this post: Same ID to elements on different scenes

The thing is, the selector is working fine on all other scenes except 403 and 404, even though I have made no special change to those scenes.

Now I see what you mean it because

So please use a document name other then just a number.


@jonathan this seams to be a bug in Hype! As this rule exists Hype has to fix the document ID accordingly and not just use the file name in such a case.

API affected:

1 Like

Good call; looks like older getElementByID() APIs have no problem with an ID named this way but querySelector() isn’t too happy.

1 Like

I’ll be fixing currentSceneElement (until it makes it into the official API, hurray!) with the workaround suggested in the article above. So I guess this is one to remember when writing extensions or are you considering to write a new rule for Hype generating ID’s? If it’s a rule only targeting the number exception this would also introduce an inconsistency. If you consider prepending some chars that would break backwards compatibility. So every route has it’s back draws as far as I can tell.

As long as the workaround mentioned in the article works maybe it’s a good solution for now.

In the longrun prepending chars would be the radical solution to fix it in a consistent way against user naming. Then you could put this new naming scheme in the Hype setting, allowing to enable legacy naming with a checkbox.

The final option, most easily done, would be to fix it in the GUI. Just don’t allow naming scenes starting with a number. Boom done!

Best regards

I’m for not encoruage it and if it exists in an old doc that is opened a warning to consider changing it.
New elements in the old doc not allowed to use it.
And not allowed at all new Documents.
(Probably not feasable ? )

This does fix the problem on 403 and 404. But, any idea about the problem number 1 mentioned in the opening post?

Do you have a version of the document that is causing that? I can see it on the live URL but not the old doc that I had around. Can you repro it from previewing the Home scene?

(PS @MaxZieb all good points about the IDs)

1 Like (368.9 KB)

This document is doing it.

This error is because you are removing nodes from the DOM that Hype is expecting to manipulate/animate in some fashion.

Instead of code like:


I’d recommend just setting the display to none: = "none";

If you must remove the node, then perhaps have it be as the inner html of a Hype element, and do not remove the Hype element.


Yeah, that’s it! Thanks a lot!

1 Like