Blur going from 0 to 10 in 1 frame


(Carlos Eduardo) #1

Sorry guys! I’m always the one complaining about blur… hahahah I just like it a lot.

My co-worker worked on an awesome animation and I noticed that the blur isn’t transitioning smoothly. I tried it on Chrome and Safari… Had the issue on both.

I had talked about this before and I’m not sure if it was fixed since then, and this is a new problem or if it’s the same. Blur sticking to integer values?

Here’s the ad in question. 336x280.zip (61.7 KB)


(Jonathan Deutsch) #2

Do you mind sending a zip of the .hype document? I’d be useful to point out which animation is particularly bad for you - they seem to be pretty quick for my eye!

One of the issues with blurs is that they perform very differently based on the rendering mode the browser is using (aka graphics acceleration or not enabled). Hype has a large decision tree to decide to use the graphics acceleration for given elements, so it could be that even though you are requesting a blur there’s another effect causing it to use a slower mode.

(Also the document from the other post looks fine to me now, so I think the cause of that was fixed).


(Carlos Eduardo) #3

DBM.zip (82.8 KB)

If you go frame-by-frame with cmd+ Right arrow, you’ll see the blur slider goes down, but the images/text only change instantly.


(Jonathan Deutsch) #4

Thanks for sending that. When an element has a scale percentage it will use an alternate rendering path that cannot render smooth blurs. This is an unfortunate browser rendering bug in Safari. If you set the scale to 100% for width/height and then instead adjust the width/height (via the Placement controls) you’ll get the achieved result in the browser.

Hype has a semi-separate bug where if you ever added a scale, it will use the alternate rendering mode. I hope to fix this in the next release. In the mean time you’d need to recreate the element and never add a scale if you don’t want to see it in Hype’s editor.


(Carlos Eduardo) #5

Awesome! Thanks for the tip! Will do that from now on!