Background-color of scenes doesn’t work as expected


(Oliver) #1

Hey guys,
For my project I need different background-colors (lightgrey and white).
To demonstrate this problem I created a new file with green and blue.

How to solve this problem?
I want my background-color to be fullscreen!

Thanks :slight_smile:



(Aleksander) #2

try this way, in the second scene (green background).

marks the boxes of both scales. You can uncheck where is “apply changes to all scenes”.


(Oliver) #3

Thank you for your tip. Unfortunately this doesn’t work for me because I need my website centered in the browser window. By activating 100% scale the central alignment is gone.


(Aleksander) #4

Keep the 100% of the scale. Then, use one of these options;

maybe you will need to group the elements.


(Oliver) #5

Thank you, first time that I get in touch with flexible layout. It also solves another problem of mine.
However this is more like a workaround? I don’t understand the idea behind this background-color behavior?


(Aleksander) #6

:ok_hand: nice!

There are other ways to solve this problem, but I chose one of them.


(Mark Hunte) #7

The Background Color does normally change to match the scene color.

Can you post your project so we can see whats going on


(Mark Hunte) #8

Ahh.

I see whats going on. The Background color is mainly for the scene but it does change the sites background color when the first scene loads. If you then go to another scene the color of the site is not updated


(Mark Hunte) #9

You could run an On Scene Load JS.

var backgroundCol = element.style.backgroundColor;
document.body.style.backgroundColor = backgroundCol;