Audio loads in preview but not when I upload to iBooks

I have authored some music instruction iBooks and use hype to make widgets showing finger position with audio. When I load the rpeview copies on my iPad, hype widgets work fine but when I upload to the iBook store, audio does not play

BTW I used mp3 format in all these widgets as advised by Hype

Did they play when you tested on your device prior to release in the iBook store? I have heard reports that MP3s do not work, but I was unable to reproduce the problem. (I also have never published in the iBooks store).

In Apple’s official support they now appear to be advising that people use the m4a file extension and to encode in AAC:

For audio, use AAC (8 to 320 Kbps, 48 kHz stereo) with an .m4a file extension.

via this support page

They also advise:

If a movie or audio file doesn’t play in your widget in iBooks Author, preview it on your iPhone, iPad or Mac. This shows how the file will play in your completed book.

So if during testing it plays but not when loaded in the iBooks store then there’s a weird bug going on in the publishing process.

The HTML widget object in iBooks Author is a wrapper for Mobile Safari so you should see the same behavior between Mobile Safari and HTML widgets except for specific pinch gestures which the HTML widget overrides.

Hi Daniel - I haven’t used this forum before, so hope I’m doing it right. Yes, they played fine on a few devices I tested with preview before releasing to the store, but not when I downloaded it and tested from the store. It sounds like AAC and .m4a extension is the way to do it.

I’m fairly cluey with audio - but might need help with Hype. I tried to upload the Hype file here for you but it wouldn’t let me - never mind. I think I get the idea. but the buttons to insert audio only allow AAC, MP3 or WAV. If I create AAC files with .m4a extension, will Hype allow me to insert that?

“The HTML widget object in iBooks Author is a wrapper for Mobile Safari
so you should see the same behavior between Mobile Safari and HTML
widgets except for specific pinch gestures which the HTML widget
overrides.” OK… I’m a bit out of my depth here but what I’m getting is maybe the way I’m dropping the widget from Hype into IBA is the problem - weird that it played fine in the preview on the device.

OK - converted files to AAC and used .m4a ext. But Hype won’t let me select that file.

Actually - only options in my version is MP3, WAV or OGA

Aha!!! I was able to add the audio file in the time line and it let me choose .m4a

BUT… when I exported it with the AAC with .m4a extension, IBA said "Your widget wasn’t added because it contains a media file that isn’t recognised.

Yes this should work fine even thought it doesn’t fit neatly into our audio group names.

Dropping the .wdgt file onto IBA is correct. And yes that’s super annoying that we’re seeing different behavior on device via IBA testing and on device when published.

A quick way to convert your audio files:

Thanks Daniel - I was using “Switch” to convert files. I’ll try this convertor and let you know. But Hype wouldn’t let me insert the AAC files with .m4a ext this morning

You can select your current audio element, and then click replace at the bottom, and then select your m4a file. Alternatively, you can drag and drop your .m4a file into the Resources Library. This will create an audio group that looks like this:

Thanks for that Daniel - looks like a newer version of Hype. I’m still on V3. If I update then follow your instructions here, that might solve it. Do you have a link for the updated Hype? I tried to do it in software update but it’s not showing up.

Ahhh… never mind, I found the update link in the App store. updating now - but have to go to work here in Australia now, so will return to the problem and let you know how I go. Thanks again.

Hype doesn’t show a “slot” for a .m4a file, however it will accept adding these types to an existing audio group or making a new audio group.

(this has been the case since v2.0 when we introduced audio)

@flippedmusic @jonathan

I routinely substitute “.mp4” in file names that have the “.m4a” suffix with no consequences - ever. Rather “.m4a”, which has been around a long time, surprisingly seems to be a problem child.

Thanks Jim. That sounds worth a try - Hype doesn’t seem to like the .m4a extension. I’ll also have a look at setting up audio groups/folders. I haven’t done that before.

Hype will think an .mp4 extension is a video file and will create a video group instead. Nor will it be selectable in the open dialog when trying to add audio. You won’t be able to use Hype’s built-in audio features with it.

Good to note. I’ve never used these features which is probably why I’ve never had these consequences. ;->

Which to me is a beautiful thing, and how I’ve used audio tracks in Hype: for syncing media and animations.

Just using the basic “.mp4” (video) track allows one to see the full length of the sound in the timeline and You can play this audio in real time in the Hype interface without going into “Preview” mode - a real time saver for animation & media syncing - something you can not do with a “.m4a” file.

Additionally, You can install a waveform visual in the “.mp4” file. An audio editor will show the waveform which You can copy and paste into QT Pro 7 (using the “Add to Selection and Scale”) and export the sound & waveform visual. This added waveform allows for quickly creating a rough layout, then fine tuning with the audio playing in the Hype interface - no “Preview” mode needed during the entire syncing process. For involved projects this is a dream.

Screen shot of the Timeline with the audio waveform depicted and matched to the audio track’s length.

Those are all good points too :slight_smile:. I definitely would like to boost up the audio feature to allow for the benefits of your solution.

1 Like