Animation choppy after Pro upgrade


#1

I just upgraded to Hype Pro today and then exported a project I was working on. Before the upgrade it was smooth but now it plays back choppy.

Is there way to fix this, or do I need to downgrade? How would I downgrade if that is my only option?


#2

I replied to your email. If you are able to share your document here I’d love to see a before and after so we can see what you’re seeing. You can always use older versions of Hype with non-upgraded .hype files, but when you open a .hype document with a newer version, the file will be upgraded.

Help > Restore Document From Export (using the version of Hype you exported with) will recover the .hype file.


#3

I’m confused. By using Help > Restore Doc… will that allow me to generate a .hype file that I can open in a non-Pro version of Hype? Also, how would I downgrade my Hype Pro to regular Hype?


(Jonathan Deutsch) #4

As an FYI, Hype Standard and Hype Pro both use the same javascript runtime; by upgrading the app there’s no differences in the output of any given document, and the Pro upgrade also does not modify documents.

The only things that have the potential of affecting performance would be changing the document itself to make use of Hype Pro features adding animation complexity - as added complexity typically has the possibility to reduce performance.


#5

The main reason that I upgraded was for the responsive features.

The only change I made to the Hype doc was to add a breakpoint and change the main containing group to scale to fit in the window for anything under 900px width. Would making such a change add any extra overhead that would affect performance?


(Jonathan Deutsch) #6

Breakpoints generally won’t cause overhead when running animations (they are only used to calculate layouts when the window size changes), but if you changed the flexible layout setting to scale and especially turned on the ‘Zoom contents’ checkbox or set flexible layout options to other elements that will definitely has performance overhead.

One easy thing to try is unchecking ‘Use WebKit graphics acceleration’ in the Document Inspector. This may be better or worse; I suspect since you have an older machine it may improve the situation as the CPU has probably aged better than the graphics card for Safari’s rendering engine.