Action simple "on click" on icon for display a text element


(Pierre) #1

Hello,

I create a lot of icons on map. When I click on icon, a box text is displayed. When I go out of the icon, the box text is hidden.
I use a specific timeline for each box text. When I click on icon 1, I start the timeline 1. And the icon 2 with the timeline 2, and so forth.

Big problem: all text boxes are positioned in the foreground and cover all the icons.
Even if I make invisible all text box (opacity 0), they are still present and do not allow to click on the icons.

How to click on all the icons even when the text box is positioned in the foreground?

Best Regards


(Pierre) #2

I attached my file:
test.hype.zip (89.1 KB)

When I click on the icon on the icon 1 and 17, no problem, the text appears correctly.

But when I click on the icon 2, my text is not displayed because the text 1 is positioned above the icon 2.

How to display text 2 if the icon 2 is positioned below the text 1?

Thanks !!!


(Steve Warby) #3

Set the display value to hidden after the opacity is 0.

I think your text opacity is set to 0 but it is still there in front of the icon.

Cheers

Steve Warby


(Pierre) #4

Thanks for your reply Steve but I don’t understand, what should I do ? Should I change the opacity on the main timeline?
Thanks !


(Pierre) #5

Hello,

If I click on “Hidden” after opacity, my text is invisible permanently :frowning:

I think I have tested everything

Can you still help me a little? It’s very important for me.

Thanks !!


(Aleksander) #6

Hi,

I have a alternative solution. Check it:

test_ FUV.hype.zip (119.5 KB)

It requires more time, but it works.

I put invisible elements in the top of the texts. The order in which you put the elements in the timeline is very important.


(Mark Hunte) #7

@mengeco

Using the example you posted,

Select each text element and in the aciton inspector. Check the ‘ignore all pointer events’

This will let you click through the text elements to anything under them that is accepting clicks or let the lower elements react to hover.

test vMH1.hype.zip (92.1 KB)


(Aleksander) #8

Thanks Mark,

I didn’t know about the function “ignore all pointer events”.


(Pierre) #9

I don’t know this option, I haven’t seen in the manual Hype.

But this is the solution! Thank you very much Mark !!!

Aleksander thank you very much! Your solution was very clever, I retain for another use;)


(Pierre) #10

Hellon,

Everything works but if I group the layers that appear on hover, it no longer works

Thanks


(Mark Hunte) #11

so do the same for the group!