Xcode/iTunesConnect has lost audio on app


has anyone had any experience of using Xcode to upload an app to iTunes connect?

I’ve just uploaded my first and it’s music dependent but for some reason, there is no sound at all on the app which was working fine before in testing on the iPad and Mac?

Could it have just had an issue in the upload?

I’m using MP3 files only.



Heh, I’m not sure. So, I did a web search. I found a forum that was discussing a similar problem. It was asked if the phone was muted.

Is it that simple? :laughing:

Haha, Ive turned the volume up and checked the mute button on the side plus it’s happening on another iPad, the project is live on the App Store so trying to get it solved asap! I’ve tested the html in Xcode Simulator by double clicking the index.html and it seems to work ok there, really odd!
Just bought your book by the way Photics, looking forward to finally getting my head around Layouts for the next project!

Could it be related to this

Thanks Mark,
I’ve looked at it and the only thing I’m slightly confused by is the ViewController file I have, as it’s using Swift as that’s the tutorial I followed on YouTube, doesn’t look like the example shown here so I’m unsure as to where I place the line of code.
Is it worth using Objective C?
Also, I’ve not used OGZ files, would it be an idea to include them as well as MP3?

You should be able to set it in swift.

I have not tried it but I would assume you put it just after where you have set up the webview.

webview.mediaPlaybackRequiresUserAction = false

Do google and also look at the apple docs on it

I’m no coder but I’ve tried dropping that line in, in a couple of places and get:
Swift compiler Error>Expected declaration (ViewController.swift)>! In declaration of "ViewController"
I looked on Google for examples and on apple docs and all they had was:
var mediaPlaybackRequiresUserAction: Bool { get set }
Under "mediaPlaybackRequiresUserAction"
I’m not even going to start on the headache I’m having with stretching to fit different screen sizes…:wink:

I rebuilt in using Objective C and included this line and the test went well, just waiting on the Review so fingers crossed!!
Thanks again!