Optimize images on export but NOT create 2x retina assets

We have had success with deleting the 2X images and then editing the HTML so that it doesn’t reference the 2X files. Just change any reference from the name of the 2X file to the standard file and it works. I was having issues where once deleting the 2X files, they would not show up in the ad. Changing the names in the HTML fixed it, and now I can meet the 1MB limit. I am also using imageoptim before import, and I don’t see any change to quality.

If your images are the wrong size when you import them (larger) – you can run these steps to just use the 1x images:

When your document is complete:

  1. Export your document without changing and ‘automatically optimize’ settings.
  2. Delete all your @2x images in the ‘hyperesources’ folder
  3. Run your entire hype resources folder through imageoptim.
  4. Replace all your images with the 1x version of your images (Select image > Click Replace in Resources Library > Select the 1x versions which have been downsized)
  5. Select all your images and uncheck ‘automatically optimize…’ at the bottom of the resources library