No sound for hype in Wordpress post

I’ve inserted a Hype document containing both visual animation and sound into a self-hosted Wordpress page. I proceeded as follows.

First, I tested the stand-alone Hype html in Safari, Chrome, Firefox and Safari iOS. All worked fine. Sound and vision.

Then I just copied the few lines of Hype HTML (the div) and inserted it into an html-capable widget in Wordpress. I edited the reference to the resources folder to correspond to where I’d uploaded it to the Wordpress site. Nothing else.

Lo and behold, it worked perfectly in all tested browsers, EXCEPT that there is no sound in any of them.

Out of curiosity, I used similar simple method to upload exactly the same Hype to an old Joomla installation. That worked fully in Safari (including sound), but no sound in Firefox and no image either in Chrome. That’s interesting, but it’s the Wordpress problem that I want to resolve.

Am I missing something simple?

Any help appreciated.

Can you share a link? Sounds like either a server or encoding issue. This might help:

I’ve got the sound working now. To be honest I’m not sure what the fault was, but I think it might have been connected with the name of the Hype project. I had a plus sign in the name, which might have caused a problem? Although everything but the audio was working correctly with that folder name. Anyway, I re-exported it with a simpler name and re-uploaded the folder to /wp-content/uploads/ and it all worked including audio. It works inside widgets, inside posts and inside Jetpack projects, and in all browsers that I’ve tried. So I’m happy!

Your comment was helpful anyway, Daniel, as I deduced from it that you thought it should work, encouraging me to press on.



Might be that plus sign – glad you found a fix!