Prevent Text selection not working

I have a scene where every single element has the “Allow text selection” unchecked, since I don’t want the user to be able to select anything on the screen.

However, when I preview a Mac build (as a desktop Mac app) through Xcode 11, the cursor often turns into a text cursor and I can select everything.

How do I prevent that? I guess I could prevent that directly in swift, but why is the Hype file not working properly?


I found a css solution that works. But I’d still like to know why it doesn’t work without it given that the selection option is unchecked in Hype.

* { -webkit-touch-callout: none; -webkit-user-select: none; }

I wasn’t able to reproduce this with a simple document, so it would be good to get files to reproduce.

I can say that Hype does not use the -webkit-touch-callout: none; property, so that might be part of the issue. If you remove this it allows selection? It would be interesting if you added this to a class and set the elements to use that class if it worked or not; that might indicate elements above in the hierarchy are responding to the selection, but perhaps not the given element.