Png problem white border


(Maximillian) #1

Hello,

I’m new here.
I would like to create a new animation.
Moving gears behind a sheet of paper. The paper I have prepared in Photoshop, shadow and saved as png.
an now i have a white border around the shadow inside.
How can I put away.

Thanks!


#2

Hi @Maximillian1001, unfortunately shadows (if you’re creating them in Hype) conform to the shape of the image (square) and not to the transparency layer of the image. While it’s a bit tricky, one option is to create a clipping path for the shape and create a shadow on that: [FREE DL] How to do advanced masking with Hype and SVG using clippath

If you’re not planning on animating the shadow, I think your best way forward is to add your shadow in Photoshop itself.


(Trey Yancy) #3

If I understand correctly, you are seeing white pixels around the shadow that you created when you output the PNG. Here’s what you need to do:

Once you have flattened the image with shadow on a transparent layer, select all (cnd-a), hold down the command key and tap the left arrow. This will isolate the pixels in the image. Release the command key and tap the right arrow to return the art to its original position. Now go to the layer menu and select Matting > remove white matte. This will clear out the unwanted pixels. You can try the other settings as well.

When you output the PNG, use Output for Web and select PNG 24. This should take care of the problem.


(Maximillian) #4

Thank you for your help.
as a matter of fact was the problem with output the png.
I’m looking for a program to use instead of Flash. And I think Tumult Hype is a good choice.
:grinning: