Import Issues using JPEG and PNG

Not sure if this is a bug but lately I've been having issues with JPEG/PNG import.
The image would not even show in Hype?
I first tried to replace an existing image and that didn't work.
Has anyone experienced something similar?
After numerous attempts at saving the file from Photoshop, I got it going.
But I can honestly repeat the issue.
What I haven't tried is a different image from the same set of images (Getty Images).
Funny Hype will import it with a name like GettyImages34837299.jpg or png but I saved it as glassSM.jpg, glass_wide.jpg, etc... and still no go.
Just a weird annoying bug.
Rebooting Mac doesnt help fix it. Thought maybe a RAM issue.

The most likely cause of an image not showing up in Hype is because the image is not a png/jpg despite the extension being labeled as such.

My flow to check this is these steps:

  1. Open /Applications/Utilities/
  2. type file (note space after file)
  3. drag in the file from the finder to the terminal window so the path appears
  4. Press return to run the file command on that file

If it says something other than a websafe format then that is the culprit and you will need to properly save/convert the file.

Otherwise it would be a shot in the dark as to what is happening; feel free to post a zip of your .hype document along with the failing images and we can take a look.