Hype and Subversion Issues


(Derek Watson) #1

We are having issues with Hype files when committing to our subversion server. The folder file structure is not being recognised properly and after initially committing as a single file, when refreshing, the file is being recognised as a folder.

Have you seen this issue before, is there any way round it?

Derek


(drewbullen) #2

I have tried several times to manage Hype projects through a version control system. It has always ended badly. No matter what VCS (including Subversion) I tried, Hype files were somehow corrupted and I was never able to utilize even the simplest branching or merging functionality.

If someone has a solution to this problem I would be very interested to learn the details of how they got it to work.


#3

What do you mean by refreshing?

The .hype file is a folder with a .plist file (text) and resources (images, videos, fonts, etc). Windows machines will see it as a folder, but Macs should understand it as an openable file. It would be great to know at what point you start to see the package corrupted. By package, I just mean a folder-understood-as-openable-package in Mac OS terminology.

If you open & edit a Hype document tracked in a version control system, scene thumbnails will be regenerated within the package, the data.plist file containing the animation + element data will change, and any resource updates will count as changes. If you move elements around, adjust timing, and make adjustments to your document the key thing you want to commit is the updates you make to the ‘data.plist’ file stored within the filename.hype ‘folder’ and of course any resource additions / adjustments.

I don’t have a lot of experience with SVN/Mercurial but so far Git for me has behaved as expected when committing .hype files.


(Derek Watson) #4

Its when we refresh in Cornerstone, the subversion client we use. It see the file initially as a single file but once controlled by subversion, it if revealed as a folder of assets. The client then gives the error that it is looking for a file and sees a folder with same name.