Can you solve this timeline problem?


#1

As a newbie to this excellent program, I’ve run across a problem I can’t solve. It involves buttons that trigger various timelines. Each timeline fades in a new picture beneath the buttons. It all works fine except, after clicking a button called Adaptable and calling its timeline, then clicking the button called Knowledgeable put some text in the wrong place.

It’s easier to understand if you see it. Go to http://www.strictlyhydraulics.com/index.php?page=home2

Click the button called Knowledgeable. You’ll see the animation proceed as intended. Then click the button called Adaptable and click the button called Knowledgeable again. You’ll see that some text appears in a different spot.

This only happens with the above sequence. Driving me nuts. Help appreciated.

File attached here: Splash.zip (598.6 KB)


#2

I believe the issue is occurring on the “shaping” timeline (triggered by the “Adaptable” button).

As part of the “shaping” timeline the “Knowledge” group is moved left to 680 pixels - where it stays - so when the “salesman” timeline runs the “Knowledge” group is revealed, but now is in the wrong spot.

When I eliminated the “Knowledge” group’s keyframes on the “shaping” timeline things seemed to work fine… but I just did basic testing.


#3

Wow! I think you’ve solved it! I thought I’d tried everything. Thanks!


(Trey Yancy) #4

One thing I had to remember early on is that the position and visibility of objects in the main timeline is inherited by the objects when they appear in other timelines. On a number of occasions I edited something in the main timeline only to find that it had changed in another timeline. (For example, if you have an item visible in the main timeline, change the opacity to zero in the additional timeline, then change the object’s visibility in the main timeline to zero, in the other timeline the visibility will show up as “-100%” and I have to set it back to zero. The same thing happens with position settings.